针对不同的jdk版本,postgresql需要使用不同的驱动程序。

JDK 1.1 ⇒JDBC 1。现在已经不支持JDK1.1了。除非是很老的项目,要不然现在也很难见到谁还在用JDK1.1版本。
JDK 1.2, 1.3 ⇒JDBC 2。
JDK 1.3 + J2EE ⇒ JDBC 2 EE. 这个版本支持javax.sql 包下面的类。
JDK 1.4, 1.5 ⇒ JDBC 3.  这个版本支持SSL和javax.sql包下面的类。
JDK 6 ⇒ JDBC4,JDBC 4.0对JDBC4方法的支持不完整,但是大多数方法已实现。

JDK7 ⇒ JDBC4,JDBC 4.0对JDBC4方法的支持不完整,但是大多数方法已实现。

JDK8 ⇒ JDBC4,JDBC 4.0对JDBC4方法的支持不完整,但是大多数方法已实现。

官方相关说明如下图:

postgresql 不同版本的jdbc驱动程序插图

更多版本直接的对照关系,可直接点击下面官方链接进行查看。

https://jdbc.postgresql.org/download.html



postgresql 不同版本的jdbc驱动程序插图(1)

关注公众号:程序新视界,一个让你软实力、硬技术同步提升的平台

除非注明,否则均为程序新视界原创文章,转载必须以链接形式标明本文链接

本文链接:https://www.choupangxia.com/2020/07/01/postgresql-jdbc-version/